Twitter is Dropping Support for Apple Devices Running iOS 11 or Older

Twitter is no longer supported on iOS 11 or earlier versions iphone ipad ipod touchBigTunaOnline / Shutterstock.com

Twitter announced yesterday via version history notes in the Apple App Store that it no longer supports devices running iOS 11 or earlier on its official app. If you are on iOS 11, you will need to update to at least iOS 12 if you want to receive regular Twitter updates.

The current version of iOS is 13.5.1, with 14 still in beta and should go out this autumn. The majority of iPhones, iPads, and iPod touch devices currently run iOS 13, so upgrading to at least iOS 12 is something to consider if you haven’t already, as other apps may start to follow suit. not. Don’t worry, because iOS 12 doesn’t remove support for any device, anyone on iOS 11 should be eligible for iOS 12.

You can easily update iOS 12 to your Apple device in a few minutes by going to Settings> General, then tapping on Software Update and tapping Download and Install. Make sure you save your information first, just in case.

Source: Twitter via 9to5Mac

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.